Guiones

En la Studio aplicación, un script es una red de acciones deClosedRealiza un proceso dentro de un estudio de secuencias de comandos, tales como la recogida de datos de clientes, reproducir un mensaje o la música, o la colocación de un contacto a un agente. esa ruta y administrar el tráfico de cliente para un centro de contacto. Por ejemplo, si un cliente llama a un centro de contacto, el cliente interactúa con un script de teléfono entrantes que pueden pedir información específica como un número de cuenta o dirigirá la llamada al departamento apropiado basado en la razón de su llamada. Cada acción en el script tiene un propósito específico, como, por ejemplo, determinar qué habilidades o variables, reproducir música en espera, o alcanzar (y pasando a lo largo de) información del cliente como nombre, dirección o número de cuenta. Las acciones se vinculan entre sí a través de conectores que determinan las posibles "vías" o ramas para que un cliente navegue por el script, como una acción Menú que brinda opciones para hablar con un agente en diferentes departamentos. Los scripts pueden tener diseños básicos, como solo enrutar un contacto telefónico directamente a un agente, o diseños más complejos que podrían incluir varias ramas que terminan en diferentes acciones basadas en una amplia variedad de parámetros.

El flujo de trabajo básico para desarrollar una secuencia de comandos es arrastrar y soltar acciones desde las pestañas Herramientas o Marco en el lienzo (que es el espacio abierto en blanco en la interfaz), y luego conectar las acciones para determinar las posibles rutas del flujo de llamadas. Después de crear la estructura básica de acciones, puede configurar cada acción aún más agregando parámetros adicionales o cargando indicaciones para reproducirlas.

Puede programar scripts para que se ejecuten en CXoneplatform, vea Programaciones de guión para más información.

Para obtener información sobre la página Scripts en el CXoneplatform, mire el Página de scripts.

Elementos de interfaz de secuencias de comandos

La imagen anterior proporciona un vistazo a la Studio interfaz de usuario. El panel central grande es el área de trabajo principal, llamada lienzo, donde colocará e interactuará con acciones para crear su secuencia de comandos. Studio ofrece una variedad de pestañas o ventanas que puede abrir y organizar en los paneles alrededor del lienzo que proporcionan acceso a los componentes que necesita para crear y administrar scripts. En esta imagen, la pestaña Herramientas aparece en el panel de la derecha, la pestaña Navegar aparece a la izquierda y la pestaña Errores de secuencia de comandos aparece debajo del lienzo. Puede hacer clic y arrastrar acciones desde las pestañas Herramientas y Marco (en el panel derecho de la imagen) al lienzo para crear un script (un administrador interno debe habilitar específicamente la pestaña Marco).

Tipos de secuencias de comandos

Puede crear un tipo específico de secuencia de comandos que se correlaciona con los diferentes canales en su centro de contacto, que se muestran a continuación:

Genérica Correo electrónico Chat Teléfono Voicemail Ítem de trabajo SMS

Al crear un nuevo script, Studio le solicita que determine el tipo de script que desea crear. El tipo de script que elija debe correlacionarse con el tipo de enrutamiento (u otra tarea) que desea lograr; la mayoría de las acciones funcionan en cualquier tipo de script, sin embargo, algunas solo se pueden agregar a un script específico (por ejemplo, las acciones ASRClosedReconocimiento de voz automático; permite que los contactos respondan a las indicaciones de voz grabadas hablando, presionando las teclas de su teléfono o una combinación de ambas. funcionan con scripts telefónicos). Si intenta utilizar una acción de la pestaña Marco que no es compatible con el tipo de script que está creando, Studio muestra un mensaje de error. Además, las acciones que no son compatibles con un determinado tipo de script no aparecerán en la pestaña Herramientas de ese script.

Además de estos tipos de script principales, Studio ofrece algunas plantillas de script en función de las funciones y aplicaciones que ha habilitado con su sistema, como el script de supresión de llamadas relacionado con Personal Connection. Si tiene acceso a estas plantillas, puede acceder a ellas en la sección Plantillas disponibles del cuadro de diálogo Crear nuevo script.

Conectores y Ramas

Conectores

Un conector es una conexión individual entre dos acciones. Se muestra como una flecha y determina el posible movimiento de un contacto de una acción a otra, más la condición de un contacto que sigue a ese conector. Puede conectar 2 acciones haciendo clic en la esquina inferior derecha de una acción y arrastrando y soltando el conector a la siguiente acción en el flujo. Para ayudar a mantener su secuencia de comandos limpia y organizada, puede doblar los conectores presionando y manteniendo CTRL y CAMBIO en el teclado, coloca el cursor sobre el conector para que se vuelva azul, haz clic derecho en el conector para colocar un cuadro verde (que será un punto de pivote), luego haz clic izquierdo en el cuadro verde y maniobra el conector como desees. Puede colocar múltiples puntos de pivote a lo largo de un solo conector para una maniobra aún más personalizada.

Branches (caminos)

Una rama es una ruta que divide un script en 2 o más subdivisiones, que comienza con un solo conector. Muchas acciones contienen opciones de ramificación predeterminadas para que configure, como Defecto o OnError, pero también puede crear condiciones de bifurcación personalizadas (llamadas condiciones de bifurcación variable) cuando aparece la ventana PickBranch después de conectar 2 acciones. La imagen anterior en el menú desplegable muestra un ejemplo básico de 3 ramas y conectores: información, facturación y soporte técnico. Los primeros conectores de cada rama están etiquetados y también muestran las 3 opciones de menú. Muchos scripts serán mucho más complejos de lo que se muestra en el ejemplo con ramas más desarrolladas. Si las ramas se vuelven demasiado complejas y extensas para ajustarse intuitivamente a 1 lienzo, el scripter podría separar las ramas en sub-scripts individuales, luego hacer referencia a los sub-scripts del script principal usando una acción Runsub o Ejecutar script. Esta es una excelente manera de mantener sus scripts organizados y ordenados en lugar de grandes, desordenados y confusos.

Por ejemplo, en las siguientes imágenes de script puede ver que el menú Yggdrasil proporciona 8 opciones para los otros 8 mundos nórdicos, y cada mundo representa una rama diferente del script. Si Heimdallr, guionista de la línea directa de Asgard, quisiera incluir más opciones para cada rama que haría que este script fuera demasiado complejo, podría crear un sub-script separado para cada uno de los otros 8 mundos. Después de hacerlo, Heimdallr usaría una acción Runsub o Ejecutar script para cada opción de menú que inicia/hace referencia al script separado cuando el contacto lo selecciona.

API de script

Para desarrolladores de scripts más avanzados, puede abrir y guardar scripts mediante programación para ayudar con los procesos de desarrollo automatizados. Expanda los siguientes menús desplegables para ver los detalles básicos de cada API.

Tips & Tricks Scripting

  • Cambiar el nombre del título en una acción puede hacer que el script sea mucho más fácil de leer y seguir. Editar un título de la acción en el cuadro de diálogo Propiedades .
  • Cuando usa Menú (o una acción similar), cree una rama para repetir las opciones del menú utilizando las acciones Lazo y Ninguna respuesta que se conectan de nuevo a la acción Menú.
  • Agrega una acción Espere después de una acción Música para reproducir la música (de lo contrario, el audio se reproducirá durante 30 segundos y luego finalizará).

  • Asegúrese de que no haya un callejón sin salida. Los callejones sin salida pueden ser problemas como ramas que faltan en un menú, ramas de menú que no están configuradas o (como en el elemento anterior) acción do no Esperar después de una acción Música.
  • Al crear un menú, es mejor nombrar primero el departamento y luego el número para marcar/hablar. Los contactos son generalmente escuchar para el nombre del departamento y el número.
  • Utilizar la acción Anotación para agregar notas o instrucciones a lo largo de un script.
  • Use el nombre del script para título de acción de Empezar
  • Las acciones Tocar y Menú, haga doble clic en la acción y anote el verborrea de la solicitud en el campo Frase.
  • Vea el historial de un script haciendo clic derecho en el script en la pestaña Examinar (Ver > Navegador) y flotando sobre la opción Historia . Esto le permite ver las iteraciones anteriores de un script.